BFS Sendungen - Keine Quittung sedex

BFS Sendungen - Keine Quittung sedex

Info

Dieser Eintrag beschreibt den Workaround für den Fall, dass keine Quittung vom sedex-Adapter empfangen wird und dadurch der Statistik-Export blockiert ist. Die Ursache liegt beim sedex-Adapter; die Verantwortung zur Behebung liegt beim IT-Dienstleister.


Fehlermeldung (Printscreen)

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Nachricht für interne IT oder IT-Dienstleister des Kunden

Im Rahmen eines Supportfalls wurde festgestellt, dass in KLIBnet keine Quittungen von sedex empfangen werden. Die Diartis AG leistet hierzu keinen Support. Die Verantwortung für den sedex-Adapter liegt bei der IT des Kunden. Eine mögliche Ursache ist folgende:

Ursache:
Bei der Installation des sedex-Clients wurde die Option «Enable the REST API for messaging» aktiviert. Dadurch wird der Empfang von Nachrichten standardmässig über die REST-API abgewickelt, nicht über die klassischen Verzeichnisse (inbox, receipts etc.).

Da KLIBnet die Quittungen über das Dateisystem (Verzeichnisse) abruft und nicht über die REST-API, gelangen die Quittungen nicht wie erwartet ins System.

Lösung 1:
Bei einer Neuinstallation des sedex-Clients. Die Option «Enable the REST API for messaging» darf während der Installation nicht aktiviert werden.
Die entsprechende Einstellung befindet sich im Schritt 15 von 23 im Installer des sedex-Clients (Screenshot).

image-20250730-064518.png

Weitere Informationen:
Run the installer program – sedex-Client

Lösung 2:
Falls der sedex-Client bereits installiert ist und die REST-API irrtümlich aktiviert wurde, lässt sich dies nachträglich direkt über die zentrale Konfigurationsdatei korrigieren.

  1. Die Konfiguration erfolgt über die Datei: <sedex_home>/conf/sedex-client-configuration.properties Der Platzhalter <sedex_home> steht für das Hauptverzeichnis der sedex-Client-Installation.

  2. Suchen Sie in der Datei nach folgender Einstellung: messaging.interface.rest-api.enabled

  3. Wenn der Eintrag vorhanden ist und auf true steht, muss er auf false geändert werden: messaging.interface.rest-api.enabled=false

  4. Damit die Änderung wirksam wird, muss der sedex-Client neu gestartet werden:

Wichtig:
Die Diartis AG leistet hierzu keinen Support. Bei technischen Fragen zur sedex-Installation oder zum Verhalten des sedex-Adapters ist direkt der sedex Support zu kontaktieren:

E-Mail: sedexsupport@bfs.admin.ch

Telefon: +41 800 866 700

Supportzeiten: Montag bis Freitag zwischen 08.30–12.00 Uhr und 13.30–16.00 Uhr


Workaround

  1. Konfiguration - Allgemein -INIs

  2. Section BfsSendungen aufrufen

  3. INI mit Keyword LetzteBfsMessageId wählen

  4. Mutieren

  5. Value löschen

  6. Speichern

INI LetzteBfsMessageId

Testen

  1. Auswertungen - Allgemein - BFS Sendungen öffnen

  2. BFS Daten manuell versenden drücken

  3. Daten sollten nun versendet werden können


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